You are running PHP 5.5.9-1ubuntu4.22, but Grav needs at least PHP 7.1.3 to run.